Benutzer-Werkzeuge

Webseiten-Werkzeuge


rechnung

Bestellzusammenfassung oder Rechnung erstellen

Auf dieser Seite erklären wir die relevanten Einstellungen innerhalb des Managements-Umgebung und geben Tipps, wie eine Rechnung in Excel erstellt werden kann. Das von uns verwendete Beispiel ist hier online testbar und das entsprechende Excel ist hier zum Herunterladen.

Standardmäßig sendet Einfachzubestellen.de bei einer Bestellung einen Exel-Anhang an den Kunden, der die sichtbaren (Online-) Tabs und die vom Kunden eingegebenen Werte enthält (Abbildung 1 links). Als Besitzer des Bestellformulars erhalten Sie immer das Original-Excel mit allen Tabs, Werten und Formeln ausgefüllt (Abbildung 2 Mitte).

Wir können uns jedoch auch dafür entscheiden, nur eine bestimmte Tab an die Kunden senden zu lassen. Diese spezifische Tab kann jede beliebige Tab im Original-Excel sein und ist daher nicht auf die sichtbaren (Online-) Tabs beschränkt. So können Sie z.B. anstelle der Online-Version des Excel (Abbildung 3 rechts) eine Bestellzusammenfassung oder Rechnung an Kunden senden.

.

Wenn Sie bereits ein Excel hochgeladen haben und wissen, welche Tab Sie angeben möchten, gehen Sie zu Managements-Umgebung, um die Einstellungen zu ändern.

Schritt 1: Fügen Sie eine Tab hinzu, die alle möglichen Eingabewerte enthält

Genau wie beim Sammeln von Excel Bestellungen in einer Excel-Übersicht fügen wir als Erstes einen zusätzlichen Tab in das Excel ein. Wir nennen es der Einfachheit halber 'Reihe'. Für diese Tab ist das Layout nicht relevant: Wir behalten also das Standardlayout von Excel bei.

Wir verwenden die Spalte 'A' noch nicht (dies wird später wiederkommen) und füllen die Spalte 'B' mit den Datenfeldern aus. In der Spalte 'C' geben wir die Formel ein, mit der die entsprechenden Werte von der Registerkarte 'DATEN' abgerufen werden.

Die Formel für Zelle 'C1' lautet: =WENN(ISTLEER(DATEN!D15);'„“;DATEN!D15)

Die Formel für Zelle 'C2' wird zu: =WENN(ISTLEER(DATEN!J15);'„“;DATEN!J15)

usw.

Hinweis: Die Formel hätte auch einfach =DATEN!D15 lauten können. Die obige Zusatzformel stellt sicher, dass, wenn in DATEN!D15 nichts eingegeben wird, auch nichts angezeigt wird. Wenn etwas ausgefüllt ist, wird der Wert von DATEN!D15 angezeigt.

Wir ergänzen die Spalten 'B' und 'C' mit den Produkten, der Anzahl und den Gesamtpreisen.

Die Formel für die Zelle 'C9' lautet: =PULLOVER!H15

Die Formel für die Zelle 'D9' lautet: =PULLOVER!K15

Die Formel für die Zelle 'C13' lautet: =HOSEN!H15

Die Formel für die Zelle 'D13' lautet: =HOSEN!K15

usw.

Die Länge (Anzahl der Zeilen) dieser Liste hängt natürlich von der Anzahl der auf allen anderen Tabs angebotenen Artikel ab. Die Spalten 'C' und 'D' können auch andere Werte als 'Anzahl' und 'Gesamtpreis' wie in diesem Beispiel haben. Auch die Anzahl der Spalten kann/darf unterschiedlich sein.

Hinweis: Je nachdem, wie die Elemente in den Tabs 'PULLOVER' und 'HOSE' angeordnet sind, können Sie die Formeln in 'C9' und 'D9' in die anderen Zellen 'C10' bis 'C12' und 'D10' bis 'D12' kopieren.

Mit dieser Tab sind wir vorerst fertig. Sie bietet jetzt eine schönen Überblick über alle Werte, die ein Kunde ausfüllt und mit einer Bestellung sendet.

Schritt 2: Fügen Sie eine Tab mit dem Rechnung-Layout hinzu

Wir fügen einen zweiten zusätzlichen Tab hinzu, die als „Rechnung“ bezeichnet wird. Dies wird die Tab sein, die wir dem Kunden senden möchten, wenn er eine Bestellung aufgegeben hat. Das Layout ist daher für diese Tab relevant. In diesem Beispiel halten wir das Layout einfach, da wir erwarten, dass Kunden oder Sie selbst diese Seite ausdrucken möchten. Also ein weißer Hintergrund, schwarze Buchstaben und wenige zusätzliche Bilder.

Wir beginnen mit der Auswahl aller Zellen (klicken Sie auf die quadratische Zelle oben links 'A1') und stellen sie entsprechend der gewünschten Schriftart, Größe, Farbe und Ausrichtung ein. Siehe Abbildung auf der rechten Seite.

Innerhalb von Excel gehen wir auf den Tab 'Bild' und klicken auf 'Seitenlayout', so dass wir nun ein Bild davon haben, wie die Notiz auf einem A4-Format aussehen wird. Siehe Abbildung auf der rechten Seite.

Wir vervollständigen die Tab mit den Details, die wir auf der Rechnung sehen möchten. In diesem Beispiel haben wir die folgenden Anpassungen vorgenommen:

  • Wir haben ein Bild als Logo hinzugefügt
  • Die Spalten 'A' und 'K' sind für die Bestimmung der Breite des Rahmens reserviert.
  • Wir behalten uns die Spalten 'B' und 'J' vor, um die Breite des Textes bis zum Rand zu bestimmen.
  • Wir verwenden Spalte 'C' als äußersten linken Rand für Text
  • Wir reservieren die Zelle 'I9' für die eindeutige Referenznummer, die bei jeder Bestellung generiert wird (mehr dazu später)
  • Wir erstellen einen Abschnitt für die ausgefüllten Adressdaten des Kunden
  • Wir erstellen eine Sektion für abgeschlossene Bestellungen mit allen Produkten, Mengen und Preisen.
  • Wir möchten den Gesamtbetrag einschließlich der Aufteilung von MwSt. zeigen.
  • Wir haben die Zellen ausgehend von Zelle 'B1' ausgewählt und den Eigenschaften der ausgewählten Zellen einen blauen Rand (Umriss) hinzugefügt

Wir werden der Tab 'Rechnung' Formeln hinzufügen, damit die Rechnung auch mit den richtigen Daten/Werten gefüllt wird.

In Zelle 'D10' wollen wir das Datum haben, an dem die Bestellung stattgefunden hat. Wir werden dafür in Excel die folgende Formel verwenden:

= HEUTE()

Wir ändern die Zelleigenschaft von 'D10' in 'Benutzerdefiniert' und dann in den Typ 'd-mm-yyyyy'.

Wenn jetzt eine Bestellung aufgegeben wird, werden alle Formeln in Excel berechnet und die Ergebnisse in die Excel-Datei kopiert. In der Zelle 'D10' wird also das Datum dieses Tages berechnet und die Zelleigenschaft zeigt dieses Datum als z.B. '29-09-2020' an.

In Zelle 'D12' wollen wir den Vornamen des Kunden. Wir rufen dies aus der Tab 'Reihe' ab.

Die Formel in 'D12' lautet: =Reihe!C1

Dies gilt auch für die anderen Daten, also

Die Formel in 'D13' lautet: =Reihe!C2 Wir füllen alle Felder der Zelle 'C21' aus. Die Werte für die Zahlen und Preise entnehmen wir der Tab 'Reihe'. Stellen Sie sicher, dass die Zellen 'F21' und weitere, und die Zellen 'I21' und weitere die richtige Zelleigenschaft haben. Also die Zelleigenschaften 'Zahl' und 'Währung - Euro'.

Die Formel in 'F21' lautet: =Reihe!C9

Die Formel in 'I21' lautet: =Reihe!D9

Bemerkungen: Auch hier ist es am einfachsten, die Formeln zunächst in Zeile 21 einzutragen und sie dann in die darunter liegenden Zellen 'F22' bis einschließlich 'F28' zu kopieren.

Nun geben wir einige Werte für den Namen und die Adresse in Excel ein und 'bestellen' 1 'Pullover B', 2 'Pullover D' und 1 'Hose C', dann sehen wir das Ergebnis auf der rechten Seite. Für eine kleine Anzahl von Artikeln mag dies ausreichend sein, aber es hat 2 Nachteile, wenn es viele verschiedene Produkte gibt, die bestellt werden können:

  1. In diesem Beispiel würden ungefähr 35 Artikel auf 1 A4 untereinander passen. Für weitere Artikel können Sie die Rechnung um eine zusätzliche Seite erweitern
  2. Die Rechnung zeigt jetzt auch Artikel, die nicht bestellt wurden. Dies macht es unübersichtlich und verwirrend.

Diese 2 Punkte werden im nächsten Schritt gelöst.

Schritt 3: Beschränken Sie die Liste auf die bestellte

Wir gehen zunächst zur Tab „Reihe“ und fügen nun in Spalte „A“ Formeln hinzu, die wir für diesen Zweck reserviert haben. Was wir erreichen wollen, ist, dass die Spalte 'A' nur dann einen Wert in einer Zeile enthält, wenn in derselben Zeile auch etwas bestellt wurde. Wir wollen auch eine fortlaufende Anzahl von Aufträgen sehen. Dazu verwenden wir die folgenden Formeln:

Die Formel in 'A9' lautet: =WENN(C9>0;1;„“)

Mit anderen Worten, wenn die in 'C9' bestellte Anzahl größer als Null ist, dann ist dieser Artikel bestellt und ansonsten ist der Wert leer.

Die Formel in 'A10' lautet: =WENN(C10>0;ZÄHLENWENN(A$9:A9;„>0¨)+1;“„)

Mit anderen Worten, wenn die in 'C10' bestellte Anzahl größer als Null ist, dann ist dieser Artikel bestellt. Die Sequenznummer dieser Bestellung hängt von der Anzahl der über Zelle 'A10' bestellten Artikel ab.

Die Formel in 'A11' lautet: =WENN(C11>0;ZÄHLENWENN(A$9:A10;“>0„)+1;“„)

usw.

Hinweis: Durch Verwendung von 'A$9' anstelle von 'A9' in der Formel können wir die Formel von Zelle 'A10' in alle zugrunde liegenden Zellen kopieren.

Das Ergebnis dieser zusätzlichen Formeln ist auf der rechten Seite zu sehen: Unter 'bestelt' sehen wir, dass nur in den geordneten Zeilen ein Wert in der Spalte 'A' und auch in aufsteigender Reihenfolge von 1 bis 3 steht.

Wir gehen nun zur Tab 'Rechnung'.

In Spalte 'B' aus Zelle 'B21' füllen wir die Zellen mit den fortlaufenden Nummern 1, 2, 3, 4, 5 usw. Diese Nummerierung bestimmt die maximale Anzahl der Artikel, die auf dem Zettel erscheinen können. In diesem Beispiel haben wir also nur 8 eindeutige Artikel, so dass wir bis 8 durchnummerieren. Angenommen, Sie haben 200 verschiedene Artikel, dann können Sie auch eine Anzahl von z.B. bis zu 30 wählen. Das Risiko besteht darin, dass, wenn ein Kunde mehr als 30 verschiedene Artikel bestellt, nur die ersten 30 auf der Rechnung erscheinen. Selbstverständlich erhalten Sie als Eigentümer die vollständige Bestellung. Immerhin erhalten Sie das Original-Excel.

Wir passen die Spalten „C“, „F“ und „I“ an, in denen Artikel, Zahlen und Preise erscheinen müssen. Wir fügen Formeln hinzu:

Die Formel in 'C21' lautet: =WENNFEHLER(SVERWEIS(B21;Reihe!A$9:D$16;2;0);“„)

Was diese Formel bewirkt, ist Folgendes: Zunächst wird auf der Tab „Reihe“ in den Zellen „A9“ bis „A16“ nach dem Wert „B21“ gesucht. (Wir haben diesen Wert zuvor auf '1' gesetzt). Sobald es diesen gefunden hat, nimmt es den Wert aus dieser Zeile, aber aus der 2. Spalte. In unserem Fall ist diese Spalte 'B' im Tab 'Reihe'. Wenn er nichts findet, gäbe es eine Fehlermeldung, also fangen wir es mit 'WENNFEHLER' ab.

Im Klartext: Suchen Sie mir die erste Bestellung aus Spalte 'A' und geben Sie mir den Namen des Artikels in Spalte 'B'. Wenn Sie nichts finden, ist das egal.

Die Formel in 'C22' lautet: =WENNFEHLER(SVERWEIS(B22;Reihe!A$9:D$16;2;0);“„)

Die Formel ist die gleiche wie in 'C21', nur dass wir jetzt bitten, nach der zweiten Ordnung zu suchen und deren Namen aus der zweiten Spalte 'B' anzugeben.

Die Formel in 'F21' lautet: =WENNFEHLER(SVERWEIS(B21;Reihe!A$9:D$16;3,0);“„)

Die Formel ist die gleiche wie in 'C21', nur bitten wir jetzt darum, die Nummer der ersten Ordnung aus der dritten Spalte 'C' weiterzugeben.

Die Formel in 'I21' lautet: =WENNFEHLER(SVERWEIS(B21;Reihe!A$9:D$16;4;0);“„)

Die Formel ist die gleiche wie in 'C21', nur bitten wir jetzt darum, den Gesamtbetrag der ersten Bestellung aus der vierten Spalte 'D' weiterzugeben.

usw.

Hinweis: Durch die erneute Verwendung von '$'-Zeichen in der Formel können wir die Formeln aus Zeile 21 in alle zugrunde liegenden Zellen kopieren.

Das Ergebnis dieser zusätzlichen Formeln ist auf der rechten Seite zu sehen: Anstelle von Artikeln sehen wir nur die Artikel, die bestellt wurden (d.h. bei denen die Anzahl größer als Null ist).

Wir können die Tab „Rechnung“ noch etwas weiter dekorieren, indem wir alle Zellen erneut auswählen und die Hintergrundfarbe auf „weiß“ setzen. Indem auch die Textfarbe der Zellen 'A21' bis 'A28' weiß gemacht wird, werden die Zahlen 1 bis 8 für den Kunden unsichtbar.

Schritt 4: Ändern der Einstellungen ins Management-Umgebung

Nun, da das Excel fertig ist, kann es in ein Online-Bestellformular konvertiert werden. Gehen Sie zum 'Bearbeiten' des Formulars, um die anzahl der Tabs auf diese einzelne Rechnung zu beschränken. Und falls gewünscht, kann bei Zahlungen auch die mit der Bestellung verbundene eindeutige Referenznummer oder eine fortlaufende Rechnungsnummer für Zahlungen hinzugefügt werden.

In diesem Beispiel gelten die folgenden Einstellungen:

  • möchten Sie eine bestimmte Tab senden: JA
  • Wenn ja, welche Tab-Nummer: 5
  • Zelladresse für Referenznummer: 'Rechnung'!I9
rechnung.txt · Zuletzt geändert: 2020/09/29 16:05 von support

Seiten-Werkzeuge